• The iView 3500STBII Revisited



    In April 2014, I wrote a short, quick review of the iView 3500STBII in iView 3500STBII Quick Review. Since that time I've picked up a second iView 3500STBII and have been using it on a different TV (a third TV if you also remember the short piece How to get your iView, Blu Ray/DVD, and an Internet Video Player on Two TVs). I've also updated the original article when I've run across problems, fixes, ideas, and updates. In this short piece I'd like to record some of the less-than-perfect perfomances of these boxes. While overall I'm very pleased with them, there have been a few more glitches which I consider strange.

    The first to come to my notice was when my wife informed me that, when viewing a TV program while using the iView box #2, the sound would fade out and then come back periodically during a program. The second problem this box exhibited was that the picture would get darker and then it would lighten back up to normal. I tested with the same TV directly connected to the coax and I did not notice these problems; switching back to the iView caused these problems to reappear.

    I think I have found a work-around to the audio fading problem. I noticed that the iView audio was very low, around 10 - 20% full scale, and the TV audio was way up, at about 90% full scale. Once I turned (clicked really) the iView audio to about 90% and turned down the TV audio so that the TV audio would be about the same - with or without the iView in-line - I no longer noticed the audio fading problem. I have tested this method during an hour long program and it seems to be a valid work around. When using the iView #1 box I have always used it with the iView audio at about 90% and have never noticed this problem. On the other hand the #1 box has never exhibited the fluctuating brightness problem either.

    I have sent a few emails to iView and received nothing in return as yet. I called and was told to return the box from the place I purchased it but before doing that to please try a new firmware upgrade which they would send me. The firmware has not arrive yet. When it does and I test it out I'll add the information here. NOTE: both of my iView boxes have the channel 3/4 switch on the back and the firmware on the website cannot be used in these boxes.

    The next problem was experienced in early September 2014 when I wanted to record a program. I turned on the iView #1 box and noticed that there were no TV programs on any of our channels. Since this box is fed by a cable coming from a splitter and the other cable from that splitter goes directly to the TV so we can watch one program while recording another, I switched to the TV and found all stations were fine. I then swapped the cables on the splitter and found the TV still worked and the iView box did not. I concluded that either the problem was the cable to the iView box or the iView box itself. Since the cable is behind everything and goes through a conduit to get to the iView box, I thought the most likely problem was the iView box itself.

    I turned off the iView and then I unplugged the iView from the AC power. I left it like that for one day and made no other changes to cables or splitter. The next day I plugged it back into the AC and turned it back on and all the stations were back. I doubt that I had to wait a full 24 hours to clear out the problem; probably five or so minutes would have done the trick. However, the trick is that the iView had to be unplugged so that the box would reboot.

    So, my advice is that if the iView is doing something strange, such as not being able to tune in your TV programs, and nothing else has changed, try unplugging the box from the AC for five to ten minutes and then try again. If that doesn't work, you can try the same thing for 24 hours. If it still has the problem, then contact iView to find out if anything can be done other than sending the box back for repair.

    I'll keep you informed of the video-fading problem if I ever get in touch with iView.

    December 18, 2015

    The fading issues, both audio and picture brightness were both due to a defect in the TV being used. I discovered this by switching iView boxes to different TVs and the problem was still with the one TV only. Once the TV was repaired the fading issues vanished.


    All my blog articles are listed at: Karras' Corner
    or
    Karras' Corner Article Links on my KE3FL web site.

    Like what you've read? Register and leave a comment...
    Already registered here? Type away!
    Comments 1 Comment
    1. PhilK's Avatar
      PhilK -
      I've added an update as of Dec 18, 2015 on the fading audio and picture brightness issues. Always go to the bottom of the article to see if there have been any updates.